View Issue Details

IDProjectCategoryView StatusLast Update
0002246NoesisGUIUnity3Dpublic2022-03-03 15:11
ReporterEnergyNick Assigned Tojsantos  
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionduplicate 
Product Version3.1.2 
Target Version3.1.3Fixed in Version3.1.3 
Summary0002246: Unity 2021.2.8f build issue
DescriptionCan't build to Unity 2021.2.8f with Noesis 3.1 and 3.1.2 for WebGL.

Exception on build:

Building Library\Bee\artifacts\WebGL\build\debug_WebGL_wasm\build.js failed with output:
wasm-ld: error: C:\\Users\\nsika\\AppData\\Local\\Temp\\tmptwgboul7Noesis.a(Noesis_wrap.o): machine type must be wasm32 or wasm64
wasm-ld: error: C:\\Users\\nsika\\AppData\\Local\\Temp\\tmptwgboul7Noesis.a(Extend_wrap.o): machine type must be wasm32 or wasm64
wasm-ld: error: C:\\Users\\nsika\\AppData\\Local\\Temp\\tmptwgboul7Noesis.a(UnityBindings.o): machine type must be wasm32 or wasm64
wasm-ld: error: C:\\Users\\nsika\\AppData\\Local\\Temp\\tmptwgboul7Noesis.a(ExtendBindings.o): machine type must be wasm32 or wasm64
wasm-ld: error: C:\\Users\\nsika\\AppData\\Local\\Temp\\tmptwgboul7Noesis.a(Events_wrap.o): machine type must be wasm32 or wasm64
wasm-ld: error: C:\\Users\\nsika\\AppData\\Local\\Temp\\tmptwgboul7Noesis.a(CoreBindings.o): machine type must be wasm32 or wasm64
wasm-ld: error: C:\\Users\\nsika\\AppData\\Local\\Temp\\tmptwgboul7Noesis.a(SWIGDefinitions.o): machine type must be wasm32 or wasm64
wasm-ld: error: C:\\Users\\nsika\\AppData\\Local\\Temp\\tmptwgboul7Noesis.a(RenderBindings.o): machine type must be wasm32 or wasm64
wasm-ld: error: C:\\Users\\nsika\\AppData\\Local\\Temp\\tmptwgboul7Noesis.a(UnityDeviceGL.o): machine type must be wasm32 or wasm64
emcc2: error: '"C:/Program Files/Unity/Hub/Editor/2021.2.8f1/Editor/Data/PlaybackEngines/WebGLSupport/BuildTools/Emscripten/llvm\wasm-ld.exe" @C:\Users\nsika\AppData\Local\Temp\emscripten_e3ckgxre.rsp' failed (1)
UnityEditor.GenericMenu:CatchMenu (object,string[],int)
TagsUnity, Unity URP
PlatformWebGL

Relationships

duplicate of 0002220 resolvedjsantos [Unity] Update Emscripten to 2.0.19 

Activities

EnergyNick

EnergyNick

2022-01-23 12:44

reporter  

settings2.png (14,038 bytes)   
settings2.png (14,038 bytes)   
settings1.png (39,809 bytes)   
settings1.png (39,809 bytes)   
jsantos

jsantos

2022-01-24 12:05

manager   ~0007755

We are going to update or plugin to Emscripten to 2.0.19 to be compatible with Unity 2021.2+

For now, the workaround is using Unity 2021.1 or earlier.

Issue History

Date Modified Username Field Change
2022-01-23 12:44 EnergyNick New Issue
2022-01-23 12:44 EnergyNick Tag Attached: Unity
2022-01-23 12:44 EnergyNick Tag Attached: Unity URP
2022-01-23 12:44 EnergyNick File Added: settings2.png
2022-01-23 12:44 EnergyNick File Added: settings1.png
2022-01-24 12:04 jsantos Relationship added duplicate of 0002220
2022-01-24 12:04 jsantos Assigned To => jsantos
2022-01-24 12:04 jsantos Status new => assigned
2022-01-24 12:04 jsantos Target Version => 3.1.3
2022-01-24 12:05 jsantos Note Added: 0007755
2022-03-03 15:11 jsantos Status assigned => resolved
2022-03-03 15:11 jsantos Resolution open => duplicate
2022-03-03 15:11 jsantos Fixed in Version => 3.1.3